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WORKSHOP 1

SOLID-TO-SOLID CONTACT
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• Workshop Objectives

– To perform a start to finish solid to solid contact analysis with MSC Nastran

– To gain familiarity with the Patran contact analysis GUI

– To investigate how to conduct a contact analysis with two bodies that have
different mesh densities

• Software Version

– MSC Nastran 2013.1

– Patran 2013

• Required Files

– search_order_start.ses
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• Problem Statement

– This problem will include a mounting bracket that has a coarse mesh and a
loading block that is more finely meshed. The mounting bracket has a
fixed boundary condition of 0 on its left face. The loading block has a force
on its right face pushing it a total displacement of .003 inches into the
mounting bracket.

Mounting bracket

Loading block

Fixed BC

Displacement BC
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• Suggested Steps

1. Create a new database called Contact_Search_order.db

2. Build the starting model by running the session file
search_order_start.ses.

3. Review the load and constraints on the model.

4. Define two deformable contact bodies using the Contact Bodies/Pairs
Tool based on connectivity

5. Set up and Run the Analysis.

• Set Solution Type to SOL101

• Request MASTER/DBALL for Results Output Format.

• Request contact results output

• Run the analysis

6. Review the MSC Nastran input file.

7. Attach the Master result file.

8. Plot deformation and von Mises stress results

9. Create a New Body Pair between the two Deformable Bodies and select
automatic contact detection

10. Rerun the Analysis File
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• Suggested Steps (Cont.)

11. Attach the New Masters Result File

12. Plot the new deformation and von Mises stress Results

13. Make a Marker Plot of Contact Status.

14. Plot Normal Contact Force as a Vector Plot on both bodies.

15. Display a Fringe Plot of Contact Status on both bodies.

16. Display a Fringe Plot of Normal Contact Stress on both bodies.
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b c

d

Create a new database:

a. Pull down File > New.

b. Enter contact_search_order as the file
name.

c. Click OK.

d. For New Model Preference, accept all defaults
by clicking OK.

Step 1. Create New Database

a
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Build a starting model by running a
session file:

a. Pull down File > Session > Play…

b. Select search_order_start.ses

c. Click Apply to play the session file.

Step 2. Run the Session File

a

b

c
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Review the model:

a. Click Smooth Shaded in the
Display group.

b. Review boundary conditions:
The left solid block is fixed at
one face.

c. Review loading: An enforced
displacement of 0.003 is
applied to the right block to
push it into the left block.

Step 3. Review the Model

a

b

c
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Define Contact Bodies using the
Create Contact Body/Pair Tool:

a. Pull down Tools > Modeling >
Contact Bodies/Pair

b. Pull down Method to
Connectivity

c. Check 3D for Elements

d. Click Apply

e. Click Cancel

Step 4. Define Two Deformable Contact Bodies

c

a

b

d e
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Set Solution Type to SOL101:

a. Under the Analysis tab, click Entire
Model in the Analyze group.

b. Click Solution Type….

c. Make sure that Linear Static is
selected. (SOL 101)

d. Click Solution Parameters.

Select the Results Output Format.

e. Click Results Output Format.

f. Check MASTER/DBALL and
uncheck XDB.

g. Click OK.

h. Click OK.

i. Click OK.

Step 5. Set Up and Run the Analysis

a

e

f

g

h

b

c

i

d
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Request contact results output:

a. Click Subcases…

b. Click on Default under
Available Subcases.

c. Click Output Requests.

d. Select Contact Results.

e. Click OK.

f. Click Apply.

g. Click Cancel.

To run the analysis:

h. Click Apply.

Step 5. Set Up and Run the Analysis (Cont.)

c

b

d

e f g

a

h
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$ NASTRAN input file created by the Patran 2013 64-Bit input
file
$ translator on
$ Direct Text Input for Nastran System Cell Section
NASTRAN SYSTEM(316)=19
$ Replace the 19 in the above line with 7
$ to get a restart DBALL instead of what is currently written
$ Direct Text Input for File Management Section
$ Direct Text Input for Executive Control
$ Linear Static Analysis, Database
SOL 101
CEND
$ Direct Text Input for Global Case Control Data
TITLE = MSC.Nastran job created on
ECHO = NONE
SUBCASE 1

SUBTITLE=Default
NLPARM = 1
BCONTACT = ALLBODY
SPC = 2
LOAD = 1
DISPLACEMENT(SORT1,REAL)=ALL
SPCFORCES(SORT1,REAL)=ALL
STRESS(SORT1,REAL,VONMISES,BILIN)=ALL
BOUTPUT(SORT1,REAL)=ALL

$ Direct Text Input for this Subcase

Review the MSC Nastran input file:

a. In the training directory locate and open
the file contact_search_order.bdf with
any text editor.

b. Note the Case Control entry BCONTACT
= ALLBODY indicates that all contact
bodies can potentially contact each other.

Step 6. Review MSC Nastran Input File

a b
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Attach the Master result file:

a. Under the Analysis tab, click
Master/DBALL in the Access
Results group.

b. Select contact_search_order
under Available Jobs.

c. Click Apply.

Step 7. Attach Master Result File

a

b

c
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Plot deformation and von Mises stress:

a. Under the Results tab click
Fringe/Deformation in the Quick Plot
group.

b. Select Stress Tensor for Fringe Result.

c. Select Displacements, Translational for
Deformation Result.

d. Click the Deform Attributes icon

e. Select True Scale.

f. Click Apply.

g. Click Reset Graphics

Step 8. Plot Deformation and Stress Results

b

c

e

a

g

e

f

d

The master and slave
have been incorrectly
selected, causing this
result. We will now
switch the bodies
selected as master and
slave.
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Create a new Body Pair and select
automatic Contact Detection:

a. Under the Load/BCs tab click
Create Body Pair in the Body
Pairs group.

b. Enter Automatic_Contact for
New Set Name.

c. Click Input Data…

d. Select Automatic for Contact
Detection

e. Click OK

f. Click Select Application Region

g. Click FEM and then Elements on
the Picking Filters toolbar

h. Click in the Body1 Name box and
select any element in 3D_bdy1
(the more finely meshed body)

i. Repeat steps g and h with Body2
Name and 3D_bdy (the more
coarsely meshed body)

j. Click OK

k. Click Apply

Step 9. Create Body Pair

b

c

e

fd

a

g
g

h

i

j

k
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Rerun the Analysis

a. Under the Analysis tab click Entire
Model in the Analyze group.

b. Enter contact_search_order_paired
for Job Name

c. Click Apply.

Step 10. Rerun the Analysis

b

c

a
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Attach the Master result file:

a. Under the Analysis tab, click
MASTER/DBALL Attachment
in the Delete Group.

b. Select the previous attachment
under Existing Files

c. Click Apply.

d. Click MASTER/DBALL in the
Access Results Group.

e. Click
contact_search_order_paired
under Available Jobs

f. Click Apply.

Step 11. Attach New Master Result File

b

c
f

d a
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Plot deformation and von Mises stress:

a. Under the Results tab click Fringe/Deformation in the
Quick Plot group.

b. Select SC1:DEFAULT, A1:Static Subcase for Select
Result Cases.

c. Select Stress Tensor for Select Fringe Result.

d. Select Displacements, Translational for Select
Deformation Result.

e. Click the Deform Attributes icon

f. Select True Scale.

g. Click Apply.

Step 12. Plot New Deformation and Stress
Results

b

c

d

a

f

g

e
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e
f

g

Create a Marker Plot of
Contact Status on the
mounting bracket.

a. View just the mounting
bracket (on the left) by
pulling down Group >
Post and posting the
mounting_bracket group.
Click Apply. (Not shown)

b. Pull down Create >
Marker > Scalar.

c. Select Contact Status for
the Scalar Result.

d. Click the Display
Attributes icon.

e. Pull down Scalar Style,
pick the Solid Sphere.

f. Set Scale Factor to .03

g. Click Apply.

h. The solid sphere markers
appear on the mounting
bracket as shown.

Step 13. Make Marker Plot of Contact Status

b

c

Create a marker plot of Contact Status on the
loading block:

i. View just the loading block (on the right) by
pulling down Group > Post and posting
the loading_block group. Click Apply.
(Not shown)

j. When the block is displayed it should have
the solid sphere markers as shown above.

k. When finished observing the markers, click
Reset Graphics to remove them.

Contact Status
Marker Plots

h j
d

k
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Plot Normal Contact Force Vector on the mounting bracket:

a. View just the mounting bracket by pulling down Group > Post and posting
the group mounting_bracket. Click Apply. (not shown)

b. Pull down Vector for Method

c. For the Vector Result select Contact Force, Normal.

d. Pull down Resultant for Show As.

e. Click Apply.

f. The Normal Force Vectors will appear on the mounting bracket as shown.

Plot Normal Contact Force Vector on the loading block:

g. View just the loading block by pulling down Group > Post and posting the
group loading_block. Click Apply. (not shown)

h. The Normal Force Vectors are displayed on the loading block.

i. When finished observing the vectors, click Reset Graphics to remove them.

Step 14. Plot Normal Contact Force

Contact Normal
Force

(marker plot)
f h

b

c

d

e

i
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Contact Status
(fringe plot)

Display a fringe plot of Contact Status on the mounting bracket:

a. View just the mounting bracket by pulling down Group > Post and
posting the Mounting_bracket group. Click Apply. (Not shown)

b. Pull down Object to Fringe.

c. For the Fringe Result select Contact Status.

d. Click Apply.

e. The fringe plot will appear on the mounting bracket as shown.

Display a fringe plot of Contact Status on the loading block:

f. View just the loading block by pulling down Group > Post and posting the
Loading_block group. Click Apply. (Not shown)

g. When the block appears it will be displayed with the fringe plot.

h. When finished observing the fringe plot, click Reset Graphics to clear it.

Step 15. Display a Fringe Plot of Contact Status

b

c

d

e g

h
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Contact Normal Stress
(fringe plot)d f

Display a fringe plot of Normal Contact Stress on the mounting bracket:

a. View just the mounting bracket by pulling down Group > Post and
posting the mounting_bracket group. Click Apply. (Not shown)

b. For the Fringe Result select Contact Stress, Normal.

c. Click Apply.

d. The normal stress fringe plot will appear on the mounting bracket as
shown.

Display a fringe plot of Normal Contact Stress on the loading block:

e. View just the loading block by pulling down Group > Post and
posting the loading_block group. Click Apply. (Not shown)

f. When the block appears it will be displayed with the fringe plot.

Step 16. Display a Fringe Plot of Normal Contact
Stress

b

c
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WORKSHOP 1A

DEFORMABLE TO RIGID CONTACT
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• Workshop Objectives

– To perform a start to finish contact analysis with MSC Nastran that uses
both deformable and rigid contact bodies

– To gain experience in the definition of the motion of rigid contact bodies

– To gain familiarity with the Patran contact analysis GUI

• Software Version

– MSC Nastran 2013.1

– Patran 2013

• Required Files

– latch.db
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• Problem Statement

– This problem will simulate the closing of a latch mechanism and will include
a spring clip that is compressed by moving surfaces of the closing door
mechanism

– Because of the high relative flexibility of the spring when compared to the
door, the door surfaces will be represented with rigid contact bodies

Spring
Clip

Mechanism surface 2
shown in its original
location – rotates about
its left edge .5 radians.

Mechanism surface 2
shown in its rotated state

Mechanism surface 1 –
moves laterally -0.3mm
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• Suggested Steps

1. Open the database latch.db

2. Create a deformable contact body for the spring clip

3. Create rigid contact bodies for the 2 rigid surfaces including prescribed
motions

4. Create contact pairs between the clip and the rigid bodies

5. Fix the spring clip around the rectangular hole

6. Set up and run the analysis.

• Set Solution Type to SOL400 – implicit nonlinear

• Request MASTER/DBALL for Results Output Format.

• Request contact results output

• Run the analysis

7. Review the MSC Nastran f06 file for errors.

8. Correct the normal direction of contact

9. Attach the MASTER results file

10.Plot deformation and von Mises stress results

11.Make a Marker Plot of Contact Status

12.Plot Normal Contact Force as a Vector Plot

13.Display a Fringe Plot of Contact Status

14.Display a Fringe Plot of Normal Contact Stress
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Open the database latch.db:

a. Pull down File > Open.

b. Select latch.db as the database file.

c. Click OK.

Step 1. Open the Existing Database

a

b

c
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Create a deformable contact body
for the spring clip:

a. Under the Loads/BCs tab, click
Deformable in the Contact
Bodies group.

b. Enter clip for New Set Name.

c. Pull down Target Element Type
to 2D.

d. Click Select Application
Region.

e. Click Pick All to select all the
surfaces.

f. Click Add.

g. Select the two mechanism
surfaces: Surfaces 20 and 21.

h. Click Remove.

i. Click OK.

j. Click Apply.

Step 2. Create Deformable Body

b

c

d

e
f h

i j

g

a
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a

Step 3. Create Two Rigid Contact Bodies

e

f

i

j

b

c
g

k

Create rigid contact bodies for the 2 mechanism
surfaces including prescribed motions from the Problem
Description:

a. Click Rigid in the Contact Bodies group.

b. Enter side for New Set Name.

c. Click Input Data.

d. Pull down Motion Control to Position

e. Enter <-0.3, 0, 0> for Displacement(vector).

f. Click OK.

g. Click Select Application Region.

h. Select the side surface.

i. Click Add.

j. Click OK.

k. Click Apply.

d

h

Note the direction of
the normal vectors
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Create the rigid contact bodies (cont.):

a. Enter bottom for New Set Name.

b. Click Input Data.

c. Enter <0, 0, 0> for Displacement(vector).

d. Enter 0.5 for Angular Velocity.

e. Select Node 9999 on the corner of the
bottom surface for the Rotation Reference
Point.

f. Enter <0 0 1> for the Axis of Rotation.

g. Click OK.

h. Click Select Application Region.

i. Select the bottom surface.

j. Click Add.

k. Click OK.

l. Click Apply.

Step 3. Create Two Rigid Contact Bodies (Cont.)

d

a

b

c

e

f

i
g

j

h

k

l

e

Note the
direction of the
normal vectors
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Create contact pairs between the
clip and rigid bodies:

a. Click Create Body Pair in the
Body Pairs group.

b. Enter side_contact for New
Set Name.

c. Click Select Application
Region.

d. Select the side contact body
for Body1/Master/Touched.

e. Select the clip contact body for
Body2/Slave/Touching.

f. Click OK.

g. Click Apply.

Step 4. Create Contact Pairs

b

c

d

e

f

g

a
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Create the contact pairs between
the clip and rigid bodies (cont.):

a. Enter bottom_contact for New
Set Name.

b. Click Select Application
Region.

c. Select the bottom contact body
for Body1/Master/Touched.

d. Select the clip contact body for
Body2/Slave/Touching.

e. Click OK.

f. Click Apply.

Step 4. Create Contact Pairs (Cont.)

a

b

c

d

e

f
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Fix the spring clip around the
rectangular hole:

a. Click Displacement Constraint
in the Nodal group.

b. Enter hold for New Set Name.

c. Click Input Data.

d. Enter <0, 0, 0> for Translations.

e. Enter <0, 0, 0> for Rotations.

f. Click OK.

g. Click Select Application
Region.

h. Click Curve or Edge on the
Picking Filters Toolbar.

i. Select the surface edges that
bound the hole.

j. Click Add.

k. Click OK.

l. Click Apply.

Step 5. Apply Loads and Boundary Conditions

b

c

d

e

f

g

h

i

j

k

l

a
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Set Solution Type to SOL400:

a. Under the Analysis tab, click
Entire Model in the Analyze
group.

b. Click Solution Type….

c. Select Implicit Nonlinear for
Solution Type.

d. Click Solution Parameters.

Select the Results Output Format and
run the analysis:

e. Click Results Output Format.

f. Ensure MASTER/DBALL is
checked.

g. Close all sub-menus by clicking
OK .

Step 6. Set Up and Run the Analysis

e

b

c

d

a

f

g

g

g
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Request contact results output:

a. Click Subcases…

b. Click on Default under
Available Subcases.

c. Click Output Requests.

d. Select Contact Results.

e. Click OK.

f. Click Apply.

g. Click Cancel.

To run the analysis:

h. Click Apply.

Step 6. Set Up and Run the Analysis (Cont.)

c

b

d

e f g
a

h
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Review the MSC Nastran f06 file
for errors:

a. In the training directory locate
and open the file latch.f06 with
any text editor.

b. Search on the string FATAL
and note the messages

Step 7. Review the MSC Nastran f06 File

*** USER WARNING MESSAGE 8166 (MCN1AB2D)
MASTER BODY IS SET TO RIGID AND IT CANNOT BE FLIPPED WHEN ISEARCH IS SET TO 0 OR

2 IN BCBODY1 ID=3.
*** USER WARNING MESSAGE 8166 (MCN1AB2D)

MASTER BODY IS SET TO RIGID AND IT CANNOT BE FLIPPED WHEN ISEARCH IS SET TO 0 OR
2 IN BCBODY1 ID=2.

now moving rigid surfaces into initial contact with deformable bodies

error: check the position and velocity of contact body ID= 3
========================================================
[User Information]:
During the approach stage of a CONTACT analysis, a rigid
body did not contact a deformable body within 1000 trials.
The time step per trial is chosen in such a way that the
displacement of the rigid body does not exceed 100 times
the error tolerance calculated by the Contact.
The initial distance between the rigid and deformable
contact bodies is probably too large or the rigid body
velocity has an incorrect direction.
========================================================

*** SYSTEM FATAL MESSAGE 8109 (MCN1INID)
Error encountered while sending DISTRT data to the 3D Contact Component

0FATAL ERROR

a

b

An error is encountered due
to the direction of contact for

the ‘side’ contact body.
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a

Reverse the contact side for the
‘side’ rigid body:

a. Under the Loads/BCs tab, click
Rigid in the Contact Bodies
group.

b. Pull down Action to Modify.

c. Select the side contact body.

d. Click Modify Data.

e. Check Flip Contact Side.

f. Click OK.

g. Click Apply.

Step 8. Correct the Direction of Contact
b

c

d

e

f g

Re-run the analysis (Repeat Step 6). Note the
normal vectors
now point
away from the
clip
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Attach the Master result file:

a. Under the Analysis tab, click
Master/DBALL in the Access
Results group.

b. Click Select Results File…

c. Select the latch Master result
file.

d. Click OK.

e. Click Apply.

Step 9. Attach Master Result File

a

b

c

d

e
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Plot deformation and von Mises
stress:

a. Under the Results tab click
Fringe/Deformation in the
Quick Plot group.

b. Select SC1:…A1:Time = 1.0
for Select Result Cases.

c. Select Nonlinear Stresses,
Stress Tensor for Select
Fringe Result.

d. Select Displacements,
Translational for Select
Deformation Result.

e. Click the Deform Attributes
icon

f. Select True Scale.

g. Click Apply.

h. When finished, click Reset
Graphics.

Step 10. Plot the Deformation and Stress
Results

a

f

g

h

b

c

d

e
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Create a Marker Plot of the Contact status:

a. Pull down Create > Marker > Scalar.

b. Select SC1:…A1:Time = 1.0 for Select Result Cases.

c. Select Contact Status for the Scalar Result.

d. Click the Display Attributes icon.

e. Pull down Scalar Style and pick the Solid Sphere.

f. Click Apply.

g. The solid sphere markers appear on the clip as shown.

h. When finished, click Reset Graphics.

Step 11. Creating Marker Plot of Contact Status

a

c

d

e

f

g

h

b
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Plot the Normal Contact Force Vector
for the clip:

a. Pull down Vector for Method

b. For the Vector Result select
Contact Force, Normal.

c. Pull down Resultant for Show As.

d. Click Apply.

e. The Normal Force Vectors will
appear on the clip as shown.

f. When finished, click Reset
Graphics.

Step 12. Plot Normal Contact Force

b

c

d

e

a

e

f
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Display a Fringe Plot of the
Contact status for the clip:

a. Pull down Object to Fringe.

b. For the Fringe Result select
Contact Status.

c. Click Apply.

d. The fringe plot will appear on
the clip as shown.

e. When finished, click Reset
Graphics.

Step 13. Display a Fringe Plot of Contact Status

f

a

b

c

d



NAS133, Workshop 1a, March 2014
Copyright© 2014 MSC.Software Corporation

WS1a - 22

Display a fringe plot of Normal
Contact Stress on the clip:

a. For the Fringe Result select
Contact Stress, Normal.

b. Click Apply.

c. The normal stress fringe plot
will appear on the clip as
shown.

Step 14. Display a Fringe Plot of Normal Contact
Stress

c

a

b
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WORKSHOP 2

SOLID-TO-SHELL CONTACT
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• Workshop Objectives

– Perform a start to finish solid to shell contact analysis with MSC Nastran

– Gain familiarity with the Patran contact analysis GUI

• Software Version

– MSC Nastran 2013.1

– Patran 2013

• Files Required

– solid_shell_contact_start.ses
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• Suggested Steps

1. Create a new database called solid_to_shell_contact.db

2. Play the session file solid_shell_contact_start.ses. Review the model.

3. Define two deformable contact bodies using the Contact Bodies/Pairs
Tool, one for the 3D solid and one for the 2D surface.

4. Create a body pair between the two deformable bodies and select
automatic contact detection

5. Set up and run the analysis.

• Set up a linear static analysis, SOL 101

• Request MASTER output file format

• Request contact results

6. View the MSC Nastran f06 result file to verify the analysis has run to
completion.

7. Attach the MASTER result file in Patran.

8. Review the contact analysis results on the entire model and on the
individual contact bodies.

• Create fringe plots of von Mises and Normal Contact Stress

• Create a vector plot of Normal Contact Force

• Create a marker plot of Contact Status
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Create a new database

a. Under the Home tab, click New
in the Defaults group.

b. Enter solid_to_shell_contact
as the File name.

c. Click OK.

d. Select Based on Model for
Tolerance.

e. Pull down MSC Nastran as the
Analysis Code.

f. Pull down Structural as the
Analysis Type.

g. Click OK.

Step 1. Create a New Database

b
c

d

e

f

g

a
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b

c

Play session file solid_shell_contact_start.ses to
build the model.

a. Pull down File > Session > Play…

b. Select solid_shell_contact_start.ses

c. Click Apply to play the session file.

Step 2. Play the Session File

a
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Review the model.

a. Under the Home tab, click
Smooth Shaded in the Display
group.

b. Review boundary conditions:

• The solid block is fixed at the
base.

• The plate is fixed at the right
edge.

c. Review loading: A total load of
10 lbs is applied to the plate.

Step 2. Play the Session File (Cont.)

a

b

c

b
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Define Contact Bodies using the Contact
Bodies/Pair Tool:

a. Pull down Tools > Modeling > Contact
Bodies/Pair

b. Pull down Method to Connectivity

c. Check 3D and 2D for Elements

d. Click Apply

e. Click Cancel

Step 3. Define Two Deformable Contact Bodies

c
a

b

d e
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Create a body pair and select
automatic contact detection:

a. Under the Load/BCs tab click
Create Body Pair in the Body
Pairs group.

b. Enter Automatic_Contact for New
Set Name.

c. Click Input Data…

d. Select Automatic for Contact
Detection

e. Click OK

f. Click Select Application Region

g. Click FEM entity and then Element
on the Picking Filters toolbar

h. Click in the Body1 Name box and
select any element in 2D_bdy (the
plate).

i. Repeat steps g and h for Body2
Name this time selecting an
element in 3D_bdy (the block).

j. Click OK

k. Click Apply

Step 4. Create Body Pair

b

c

e

fd

a

g

h

i

j

k
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Set up a linear static analysis.

a. Under the Analysis tab, click
Entire Model in the Analyze
group.

b. Click Solution Type….

c. Select LINEAR STATIC.

d. Click Solution Parameters.

Step 5. Set Up and Run the Analysis

a

c

d

b
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e

Request MASTER results output format to capture
contact results.

a. Click Results Output Format.

b. Check MASTER/DBALL and uncheck XDB.

c. Click OK.

d. Click OK.

e. Click OK.

Step 5. Set Up and Run the Analysis (Cont.)

d

b

c

a
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a

Request contact results.

a. Click Subcases…

b. Highlight Default in
Available Subcases.

c. Click Output Requests.

d. Scroll down and highlight
Contact Results.

e. Click OK.

f. Click Apply.

g. Click Cancel.

h. Click Apply to submit the
analysis.

Step 5. Set Up and Run the Analysis (Cont.)

c

b

d

e

f g

h
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After the analysis runs to
completion, review the .f06 results
file

a. Locate the file
solid_to_shell_contact.f06

b. Open
solid_to_shell_contact.f06
with any text editor

c. Search for the string %.

d. Scroll down the load steps,
note that Load Step 1.0000 has
been reached. Then close the
.f06 file.

Step 6. View the Result File

0 N O N - L I N E A R I T E R A T I O N M O D U L E O U T P U T

STIFFNESS UPDATE TIME-1892160000.00 SECONDS SUBCASE 1 STEP 0
ITERATION TIME 0.02 SECONDS

LOAD NO. - - ERROR FACTORS - - CONV ITR MAT NO. AVG TOTL - - - - - DISP - - - - - - LINE_S NO. TOT TOT
STEP INC ITR DISP LOAD WORK RATE DIV DIV BIS R_FORCE WORK AVG MAX AT GRID C FACT NO QNV KUD ITR

%1.00000E-01 1 1 1.00E+00 1.24E-13 1.00E+00 1.000 0 1 0 1.77E-07 2.388E-05 6.61E-06 -1.047E-04 227 3 1.00 0 0 0 1
*** SYSTEM INFORMATION MESSAGE 8137 (NL3CON)

SEPARATION condition has been detected. Additional iterations will be performed.
%1.00000E-01 1 2 5.97E-05 8.02E-14 4.66E-05 0.564 0 1 0 2.16E-09 2.388E-05 6.61E-06 -1.047E-04 227 3 1.00 0 0 0 2
*** SYSTEM INFORMATION MESSAGE 8137 (NL3CON)

SEPARATION condition has been detected. Additional iterations will be performed.
%1.00000E-01 1 3 1.44E-01 1.22E-13 7.53E-03 0.599 0 1 0 1.76E-15 2.424E-05 6.90E-06 -1.070E-04 227 3 1.00 0 0 0 3
%1.00000E-01 1 4 8.72E-02 7.90E-14 3.38E-03 0.599 0 1 0 4.69E-12 2.440E-05 6.89E-06 -1.094E-04 227 3 1.00 0 0 0 4

a

b

c

d
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Attach the MASTER results file in
Patran.

a. Click MASTER / DBALL in the
Access Results group.

b. Select solid_to_shell_contact
from Available Jobs.

c. Click Apply

Step 7. Attach the Result File

a

b

c
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Plot deformation and shell von Mises stress

a. Under the Results tab, click Fringe/Deformation in the Quick Plot group.

b. Select SC1:DEFAULT, A1:Static Subcase for Select Result Cases.

c. Highlight Stress Tensor for Fringe Result.

d. Highlight Displacements, Translational for Deformation Result.

e. Click Reset Graphics to clear the shading.

f. Click Apply.

Step 8. Review Analysis Results

c

d

e

f

a

b
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Set deformation scale to true
scale.

a. Click Deform Attributes.

b. Select True Scale.

c. Click Apply.

Step 8. Review Analysis Results (Cont.)

b

c

a
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Plot solid von Mises stresses

a. Click Select Results.

b. Click Position…(At Z2).

c. Highlight NON-LAYERED.

d. Click Close.

e. Click Apply.

Step 8. Review Analysis Results (Cont.)

b

c

e

d

a
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Plot contact status of both contact bodies

a. Click Reset Graphics.

b. Click Fringe in the Results Plots group.

c. Highlight Contact Status under Select
Fringe Result.

d. Click Apply.

Step 8. Review Analysis Results (Cont.)

c

d

b

a
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Plot contact normal stress on both
contact bodies

a. Highlight contact stress,
Normal under Select Fringe
Result.

b. Click Apply.

Step 8. Review Analysis Results (Cont.)

b

a
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Plot contact normal force on both contact bodies

a. Click Reset Graphics.

b. Click Vector in the Result Plots group.

c. Highlight contact force, Normal

d. Click Apply.

Step 8. Review Analysis Results (Cont.)

d

b

c

a
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Plot contact status on both contact bodies

a. Click Reset Graphics.

b. Pull down Scalar for Method.

c. Highlight Contact Status.

d. Click Display Attributes.

e. Pull down Scalar Style to the solid sphere (or choose your
own).

f. Click Apply.

g. Adjust the Scale Factor as desired and click Apply again.

Step 8. Review Analysis Results (Cont.)

b

c

e

f

g

a

d
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Examine the contact bodies
individually.
First post the plate.

a. Pull down Group > Post.

b. Highlight plate

c. Click Apply.

Step 8. Review Analysis Results (Cont.)

b

c

a
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Examine the plate contact body

a. Click Reset Graphics.

b. Click Vector in the Result Plots
group.

c. Click the Results tab.

d. Highlight contact force,
Normal

e. Click Apply

Step 8. Review Analysis Results (Cont.)

d

e

b

a

c
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Examine the plate contact body

a. Right-click in a blank part of the viewport and select View
Corners from the context menu.

b. Drag a rectangle to zoom in on the contact normal forces
acting on the plate

c. On the Results form, click Display Attributes

d. Experiment with Vector Definition and Label Style to help
visualize the contact force results

Step 8. Review Analysis Results (Cont.)

d

d

b

a

c
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Now examine the block

a. Click the Group tab.

b. Highlight block.

c. Click Apply.

d. Click the Results tab.

e. Click Apply.

Step 8. Review Analysis Results (Cont.)

a

b

c

e

d
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Continue to plot contact analysis
results on individual contact bodies
on your own.

Step 8. Review Analysis Results (Cont.)

Contact Status
(fringe plot)

Contact
Normal Stress
(fringe plot)

Contact
Normal Force
(marker plot)

Contact Status
(marker plot)



NAS133, Workshop 3, March 2014
Copyright© 2014 MSC.Software Corporation

WS3 - 1

WORKSHOP 3

SHELL EDGE-TO-EDGE GLUED CONTACT
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• Workshop Objectives

– Learn to create a shell edge-to-edge glued contact with moment carrying
capability.

• Software Version

– MSC Nastran 2013.1

– Patran 2013

• Required Files

– shell_edge_glue_start.bdf
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• Suggested Steps

1. Create a new database.

2. Import the MSC Nastran input file.

3. Review the model.

4. Define two deformable contact bodies using the Contact Bodies/Pairs
Tool, one for the coarse mesh global model and one for the fine mesh
local model.

5. Create a New Body Pair between the two Deformable Bodies

• Check Glued Contact, Retain Moment, Stress free InitCont

• Select automatic contact detection

• Ignore thickness for both master & slave bodies

6. Set up a linear static analysis and run the analysis

7. Review the entries BCONPRG and BCONECT in the MSC Nastran input
file.

8. Review MSC Nastran f06 result file.

9. Attach the MASTER result file.

10.Review analysis results. Plot deformation and von Mises stress results.
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Create a new database:

a. Pull down File > New.

b. Enter
shell_edge_glue. for
the File name.

c. Click OK.

d. For New Model
Preference, accept all
defaults by clicking
OK.

Step 1. Create a New Database

a

b c

d
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Import the starting finite element
model:

a. Pull down File > Import…

b. Pull down Source to MSC.
Nastran Input.

c. Select
shell_edge_glue_start.bdf.

d. Click Apply to import the
model.

e. Click OK to close the import
summary form.

Step 2. Import a MSC Nastran Input File

e

a
d

c b
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Review the model:

a. Under the Load/BCs tab, click
Plot Markers in the LBC
Actions group.

b. Shift-select both the
Displ_spc1.1 and
Force_force.1 Load/BC sets

c. Click Apply to plot the loads
and boundary conditions.

Step 3. Review the Model

a

b

c
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Step 3. Review the Model

Fine Mesh Local ModelCoarse Mesh Global
Model

200 Lb Tensile LoadFixed End
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Define Contact Bodies using the Create Contact Body/Pair Tool:

a. Pull down Tools > Modeling > Contact Bodies/Pair

b. Pull down Method to Properties

c. Click Apply

d. Click Cancel

Step 4. Define Two Deformable Contact Bodies

c

a

b

d
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Create a New Body Pair:

a. Under the Load/BCs tab click
Create Body Pair in the Body
Pairs group.

b. Enter Automatic_Contact for
New Set Name.

c. Click Input Data…

d. Check Glued Contact(IGLUE),
Retain Moment(IGLUE), and
Stress free InitCont(ICOORD).

e. Select Automatic for Contact
Detection (ISEARCH).

f. Click Contact Options

g. Check Ignore Thickness for
both Master and Slave bodies

h. Click OK

i. Click Select Application
Region

Step 5. Create Body Pair

b

c

i

a

d

e

f

g g

h
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Select Application Region:

a. Click in the Body1 Name box

b. Select FEM and then
Elements in the Picking Toolbar

c. Select any element in
pshell.1_bdy (the more
coarsely meshed body).

d. Repeat steps b and c with
Body2 Name and in
pshell.2_bdy (the more finely
meshed body).

e. Click OK

f. Click Apply

Step 5. Create Body Pair (Cont.)

c

f

d

a

e
b

b

d
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a

Set up Solution Type

a. Under the Analysis tab, click
Entire Model in the Analyze
group.

b. Enter global_local_glue for
Job Name.

c. Click Solution Type….

d. Select LINEAR STATIC.

e. Click Solution Parameters.

f. Make sure that both
Database Run and
Automatic Constraints are
checked under Static
Solution Parameters.

g. Click Results Output
Format.

Step 6. Set up a Linear Static Analysis

h

f

g

c

b

d

e
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a. Check MASTER/DBALL

b. Uncheck XDB.

c. Click OK.

d. Click OK on the Solution
Parameters form.

e. Click OK.

f. Click Apply to run the
Analysis

Step 6. Set up a Linear Static Analysis (Cont.)

i

a

b

c

d
e f
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While the job is running, review the
MSC Nastran input file.

a. Locate the file
shell_edge_glue.bdf

b. Open shell_edge_glue.bdf
with any text editor.

Step 7. Review MSC Nastran Input File

a

b

$ Direct Text Input for Nastran System Cell Section

NASTRAN SYSTEM(316)=19

$ Replace the 19 in the above line with 7

$ to get a restart DBALL instead of what is currently written

$ Linear Static Analysis, Database

SOL 101

CEND

ECHO = NONE

BCONTACT = 0

SUBCASE 1

$ Subcase name : Default

SUBTITLE=Default

NLPARM = 1

BCONTACT = 1

SPC = 2

LOAD = 3

DISPLACEMENT(SORT1,REAL)=ALL

SPCFORCES(SORT1,REAL)=ALL

STRESS(SORT1,REAL,VONMISES,BILIN)=ALL

BEGIN BULK

PARAM PRTMAXIM YES

BCPARA 0 NLGLUE 0

NLPARM 1 NO

BCTABL1 0 8005

BCONECT 8005 3004 2 1

BCONPRG 3004 COPTM 1061 COPTS 1061 ICOORD 1

IGLUE 4

BCTABL1 1 8005

$ Elements and Element Properties for region : pshell.1

PSHELL 1 1 .1 1 1

$ Pset: "pshell.1" will be imported as: "pshell.1"

CQUAD4 1 1 1 2 23 22 0. 0.

b
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BCONPRG 3004 COPTM 1061 COPTS 1061 ICOORD 1

IGLUE 3 ISEARCH 2

Review the Input File

a. On the BCONPRG entry check
that ISEARCH is equal to 2

b. Check that the ICOORD = 1

c. Check that IGLUE (moment
carrying glue) =3

Step 7. Review MSC Nastran Input File (Cont.)

a

b

c
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BCONECT 8005 3004 2 1
BCONPRG 3004 COPTM 1061 COPTS 1061 ICOORD 1

IGLUE 3 ISEARCH 2

The QRG entry for BCONECT and
note concerning COPTS1 and
COPTM1 have been copied below for
convenience
a. Notice that the BCBODY 2 is the

SLAVE and BCBODY 1 is the
MASTER.

b. The note from the QRG
concerning COPTS1 and
COPTM1 is copied here for your
convenience. Notice that in this
case:

• A = 1

• B = 6

• C=1

• so COPTS1=CPTM1= 1061.

Step 7. Review MSC Nastran Input File (Cont.)

a

b
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After completion of the run, review
the .f06 results file.

a. Locate the file
global_local_glue.f06

b. Open global_local_glue.f06
with any text editor.

c. Scroll down to the CASE
CONTROL ECHO section.
Notice no nonlinear increments
or iterations were performed. A
line solution was performed.
Scan the rest of the .f06 file
then close it.

.

Step 8. Review MSC Nastran Result File

a

c
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To attach the results file:

a. Under the Analysis tab, click
MASTER/DBALL in the Access
Results group.

b. Select global_local_glue from
the Available Jobs

c. Click Apply

Step 9. Attach Results File

a

b

c
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Plot deformation and von
Mises stress

a. Under the Results tab,
click
Fringe/Deformation in
the Quick Plot group.

b. Select Stress Tensor
for Fringe Result.

c. Select Displacements,
Translational for
Deformation Result.

d. Click Apply.

Step 10. Review Analysis Results

b

c

f

a
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Turn off the display of the
undeformed shape.

a. Click Deform Attributes

b. Uncheck Show Undeformed.

c. Click Apply.

Step 10. Review Analysis Results (Cont.)

a

b

c
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Display element edges.

a. Click Fringe Attributes

b. Pull down Display to Element Edges.

c. Click Apply.

Step 10. Review Analysis Results (Cont.)

a

b

c
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Step 10. Review Analysis Results (Cont.)

Displacement fringe plot Un-Averaged stress fringe plot

Exaggerated deformation plot

Make additional plots on
your own to evaluate the
quality of the glued joint.
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WORKSHOP 4

NATURAL FREQUENCY WITH
GLUED CONTACT
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• Workshop Objectives

– Perform a SOL103 (Natural Frequency) analysis with glued contacts on a
model of a Printed Circuit Board (PCB).

– Use of the ERROR parameter on a contact body.

• Software Version

– MSC Nastran 2013.1

– Patran 2013

• Files Required

– PCB_model.bdf
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• Problem Description

1. The model is a PCB with components soldered onto the board.

2. Glued contact will be used to model the connections between the board
and its chips. The contact bodies for this model are shown in the diagram
on the following page. Most of the chips will be combined into one contact
body except for Chips 2 and 3. Chip 2 and its leads are in their own contact
bodies because Chip 2 is not connected directly to the PCB. Instead, the
leads from this chip are connected to the PCB.

3. Chip 3 is defined as a separate contact body because it has a slightly larger
clearance than the other chips. This becomes important later since the
contact distance tolerance needs to be increased for this component in
order for glued contact to work.
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Leads

Chips
PCB

Chip 2

Chip 3

• Problem Description (Cont.)
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• Suggested Steps

1. Create a new Patran database called PCB_Natural_Freq.db.

2. Import the BDF file, PCB_model.bdf.

3. Rename the contact bodies to match the component names shown on the
Problem Description page and color code the contact bodies.

4. Verify the material properties.

5. Verify that the ends of the PCB are fully fixed.

6. Create four new body pairs between chip_3 and PCB, chip_2 and leads, leads
and PCB, and chips and PCB.

• Check Glued Contact and Stress free InitCont

• Select automatic contact detection

7. Set up and run a normal modes analysis

8. Review the eigenvalues in the result file.

9. Attach the result file.

10. View the deformed shape.

11. Measure the distance between chip 3 and the PCB.

12. Modify the chip_3_pcb contact body pair and add 0.016 as the Distance

13. Re-run the analysis.
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• Suggested Steps (Cont.)

14. Review the eigenvalues in the result file.

15. Attach the new result file.

16. View the deformed shape.
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Open a new database.

a. Pull down File > New

b. Enter PCB_Natural_Freq for File Name.

c. Click OK.

d. Click OK on the New Model Preference form to
retain the default tolerance.

Step 1. Create a Database

b c
d

a
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Import the model.

a. Pull down File > Import.

b. Pull down MSC.Nastran Input
for Source.

c. Select PCB_model.bdf as the
file to import.

d. Click Apply.

e. Check the MSC Nastran Input
File Import Summary and make
sure there are 29212 Nodes,
47352 Elements. Click OK.

f. Rotate and shade the model.

Step 2. Import the Model

dc

b

a

f

e

f
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Create groups of elements based on their associated properties. Color code the groups.

a. Pull down Group > Create.

b. Pull down Property Set and Multiple Groups for Method and Create respectively.

c. Check Post Groups, Unpost All Other Groups and Automatically Color Groups.

d. Click Apply.

e. Click Yes to the message “You have requested to color the newly created groups.
This requires the display mode to be set to ‘Group.’ Would you like me to set that for
you?”

f. Shade the model.

g. Click Cancel

Step 2. Import the Model (Cont.)

b

c

d

e

a

f

g
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e

Rename the contact bodies to
match the component names
shown in the

a. Under the Loads/BCs tab, click
Modify in the LBC Actions
group.

b. Pull down Object to Contact.

c. Highlight DEFORM.1 under
Select Set to Modify.

d. Click Modify Application
Region

e. Observe which component is
highlighted

f. Click OK

g. Enter chip_2 for Rename Set
as to match the Model
Description.

h. Click Apply

i. Repeat for:

• DEFORM.2 - chip_3

• DEFORM.3 - chips

• DEFORM.4 - leads

Step 3. Rename and Color Code Contact Bodies

b

d

c

g

h
f

a
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Rename the contact bodies to
match the component names
shown in the

a. Highlight DEFORM.5 under
Select Set to Modify.

b. Click Modify Application
Region.

c. Click OK.

d. Enter PCB for Rename Set as
to match the name in the
Problem Description.

e. Change Target Element Type
to 2D.

f. Click Apply.

Step 3. Rename and Color Code Contact Bodies
(Cont.)

a

b

c

d

f

e
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Color code the contact bodies.

a. Pull down Group > Post.

b. Highlight default_group under Select Groups to
Post.

c. Click Apply.

d. Click Cancel.

e. Pull down Plot Contours / Contact / Deformable
Body for Action, Object and Option respectively.

f. Highlight all Existing Sets using shift-click.

g. Select Group Color.

h. Click Apply.

i. Shade the model.

j. When you have finished verifying the contact
bodies, click Reset Graphics.

Step 3. Rename and Color Code Contact Bodies
(Cont.)

a

b

c d

i

j

h

g

f

e
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Check the materials.

a. Under the Properties tab, click
Show Material in the Property
Actions group.

b. Highlight mat1.1 under Existing
Materials ensure that the
material properties are identical
to the properties given in the
Model Description.

c. Repeat for mat1.2 and mat1.3.

d. Click Cancel

Step 4. Verify the Material Properties

b

d

a

c
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Check the constraints.

a. Under the Loads/BCs tab,
click Plot Markers in the
LBC Actions group.

b. Highlight Displ_spc1.1
under Assigned Load/BC
Sets.

c. Click Apply.

d. Shade the model.

e. Observe the BC markers
showing the ends of the
PCB are fully fixed.

f. Click Reset Graphics.

Step 5. Verify the Boundary Conditions

e

b

c

f

d

c

a
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Touching
Body

Touched
Body

chip_2 leads

leads PCB

chips PCB

Create Body Pairs:

a. Under the Load/BCs tab click Create
Body Pair in the Body Pairs group.

b. Enter chip_3_pcb for New Set
Name.

c. Click Input Data…

d. Check Glued Contact(IGLUE) and
Stressfree InitCont(ICOORD)

e. Select Automatic for Contact
Detection (ISEARCH).

f. Click OK

g. Click Select Application Region

h. Select PCB for
Body1/Master/Touched.

i. Select chip_3 for
Body2/Slave/Touching.

j. Click OK

k. Click Apply

l. Repeat steps b-k for the bodies
indicated in the table on the right
(follow the same naming convention)

Step 6. Create Body Pairs

b

c

i

a

d

e

f

j

g

h

k

l
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Set the Solution Type to
SOL103, Normal Modes.

a. Under the Analysis tab,
click Entire Model in the
Analyze group.

b. Enter PCB_Natural_Freq
for Job Name.

c. Click Solution Type.

d. Select Normal Modes for
Solution Type.

e. Click Solution
Parameters.

f. Enter 0.00259 for Wt.-
Mass Conversion.

g. Click OK.

h. Click OK.

Step 7. Set Up a Normal Modes Analysis

g

d

e

h

f

b

c

a
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Enter the number of desired roots.

a. Click Subcases.

b. Highlight Default under Available Subcases.

c. Click Subcase Parameters.

d. Make sure Number of Desired Roots is 10.

e. Click OK

f. Click Apply, then Cancel.

Step 7. Set Up a Normal Modes Analysis (Cont.)

c

a

b

d

d

e e
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Select the Default subcase and
run the job.

a. Click Subcase Select.

b. Select Default

c. Click OK.

d. Click Apply.

Step 7. Set Up a Normal Modes Analysis (Cont.)

c

b

d

a
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Review the eigenvalues in the .f06 file

a. Navigate to and open the file
pcb_natural_freq.f06 in a text editor.

b. Search on the string “E I G E N”

c. Check the natural frequencies.

Step 8. Review the Results File

a

There are six near-zero
natural frequencies present.
This indicates that there are
rigid body modes in the
model.

b

b

c
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Import the results.

a. Click XDB in the Access
Results group.

b. Select PCB_Natural_Freq in
the Available Jobs list.

c. Click Apply.

Step 9. Attach the Results File

a

c

b
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Plot the deformed shape.

a. Under the Results tab, click
Fringe/Deformation in the Quick Plot
group.

b. Highlight Default, A1:Mode 1 : Freq =
0.012529 under Select Result Cases.

c. Highlight Eigenvectors, Translational
under Select Fringe Result.

d. Highlight Eigenvectors, Translational
under Select Deformation Result.

e. Click the Deform Attributes icon.

f. Uncheck Show Undeformed.

g. Click Apply.

Step 10. View the Deformed Shape

a

f

g

d

c

b

e
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Step 10. View the Deformed Shape (Cont.)

One of the chip components is clearly not
glued to the board and is the source of the
rigid body modes.

Check the distance of this component from
the board and adjust the contact tolerance
(ERROR) parameter.
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Set the view to Top View for easy measuring.

a. Click Reset Graphics.

b. Under the Home tab, click Top View.

c. Click View Corners

d. Drag a rectangle around the component in question.

e. Click Smooth Shaded.

Step 11. Measure the Distance Between Chip 3
and PCB

Free
Component

d

a

bc e
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Check the component distance
from the board.

a. Under the Meshing tab, click
Show in the FEM Actions
group

b. Pull down Distance for Info to
determine the distance in the Z-
direction from the PCB to the
components.

c. First for comparison, check the
distance of the component that
is closer to the PCB. Choose a
node on the upper edge of the
component and any node on
the PCB

d. Check the distance of the free
component, Chip 3. Choose a
node on the upper edge of the
component and any node on
the PCB.

Step 11. Measure the Distance Between Chip 3
and PCB (Cont.)

d
PCB

c

Free
Component
Chip 3

b
a

Other component
closer to the board
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Check the component distance
from the board continue.

a. Note the reported Z distances.

b. Click Cancel to close the table.

Step 11. Measure the Distance Between Chip 3
and PCB (Cont.)

The standard distance of the components
from the PCB is 0.0194“. The component in
question is 0.0344” away, and is not falling
within the default contact tolerance.

PCB thickness = 0.0389”
0.0344” – 0.0389” / 2 = 0.015”
Try a Distance Tolerance of 0.016”

a

b
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Modify the chip_3_pcb body pair:

a. Under the Home tab, click
Show/Hide Model Browser
Tree in the Model Tree Group.

b. Double click on chip_3_pcb
under Contact > Body Pair

c. Enter 0.016 for Distance
Tolerance(ERROR).

d. Click OK

e. Click Apply

Step 12. Modify Body Pair

d

c

e

b

a
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Return to the Analysis form and rerun the job.

a. Under the Analysis Tab, click Entire Model in the
Analyze Group.

b. Click Apply

c. Click Yes to overwrite the old job.

d. Click Yes to overwrite the old files.

Step 13. Rerun the Analysis

b

a

c

d
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Review the f06 file.

a. Navigate to and open the file
pcb_natural_freq.f06

b. Search on the string “E I G E
N” and check the natural
frequencies.

Step 14. Review the New Results File

This time there are now no rigid body modes

a

b
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Import the results.

a. Click XDB in the Access
Results group.

b. Select PCB_Natural_Freq

c. Click Apply.

Step 15. Attach the New Results File

b

a

c
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Plot the deformed shape.

a. Under the Results tab, click Fringe/Deformation in the Quick Plot group.

b. Click Select Results

c. Highlight Default, A1:Mode 1 :Freq = 168.03 under Select Result Cases.

d. Highlight Eigenvectors, Translational under Select Fringe Result.

e. Highlight Eigenvectors, Translational under Select Deformation Result.

f. Click Apply.

Step 16. View the Deformed Shape

a

All components are
now properly glued.

d

c

e

f

b
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WORKSHOP 5

SHELL FACE TO FACE CONTACT
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• Workshop Objectives

– Create glued contact between shell faces.

– Create and view the MPCs which model the glued contact.

– See the difference in contact order on the quality of the glued contact.

• Software Version

– MSC Nastran 2013.1

– Patran 2013

• Files Required

– tee-clip_fe.bdf
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• Suggested Steps

1. Build the starting model by importing the MSC Nastran input file tee-
clip_fe.bdf.

2. Define two deformable contact bodies using the Contact Body/Pair Tool,
one for the plate and one for the tee. Color code the bodies.

3. Create a body pair between the plate and tee

• Check Glued Contact and Stress free InitCont

• Select double sided contact detection

4. Set up and run a linear static analysis:

• Set Solution Type to Linear Static

• Change the Bias Tolerance to 0.0

• Specify glued contact between the contact bodies

• Request a punch file that contains the MPCs used to model the glued contact be
saved

5. Attach the xdb results file.

6. Post-Process Results in Patran:

• Review the deformation results

• Review max Principal stress results.
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• Suggested Steps (Cont.)

7. Import the punch file that contains the MPCs. Review the pattern of
contact.

8. Modify the Body Pair to select automatic contact detection.

9. Attach the new xdb result file.

10. Create a fringe plot of maximum principal stress in the contact region.
Compare the plot to that obtained in step 6.

11. Import the punch file for this analysis. Review the pattern of contact.
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Open a new database.

a. Pull down File > New

b. Enter tee-clip.db for File name

c. Click OK.

d. Click OK on the New Model
Preference form.

Step 1. Import the Model

b c
d

a
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Import the model.

a. Pull down File > Import.

b. Pull down MSC Nastran Input
for Source.

c. Select tee-clip_fe.bdf as the
file to import.

d. Click Apply.

e. Review the MSC Nastran Input
File Import Summary then click
OK.

f. Orient the model to Iso 1 view

g. Click Smooth shaded in the
Display group

h. Click Fit view.

Step 1. Import the Model (Cont.)

c

a

d

b

f

e

g

h
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Define Contact Bodies using the
Create Contact Body/Pair Tool:

a. Pull down Tools > Modeling >
Contact Bodies/Pair

b. Pull down Method to
Connectivity.

c. Select 2D for Elements

d. Click Apply and Cancel.

e. Under the Loads Tab, select
Color Code Bodies in the
Contact Bodies Group

f. Highlight Existing Sets 2D_bdy
and 2D_bdy1.

g. Select Group Color

h. Click Apply (not shown)

i. Select Smooth Shaded.

Step 2. Define Two Deformable Contact Bodies

c

a

d

b

f

e

g

i

a
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Create a New Body Pair:

a. Under the Load/BCs tab click
Create Body Pair in the Body
Pairs group.

b. Enter plate_tee_contact for
New Set Name.

c. Click Input Data…

d. Check Glued Contact(IGLUE)
and Stress free
InitCont(ICOORD).

e. Select Double Sided for
Contact Detection (ISEARCH).

f. Click OK

g. Click Select Application
Region

Step 3. Create Body Pair

b

c

a

d

e

f

g
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Select Application Region:

a. Click in the Body1 Name text box

b. Select FEM and then QUAD Elements in the
Picking Toolbar

c. Select any element in 2D_bdy1 (the plate).

d. Repeat steps b and c with Body2 Name and
in 2D_bdy (the tee).

e. Click OK

f. Click Apply

Step 3. Create Body Pair (Cont.)

c f

d

a

e

d

b
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Set Solution Type to 101 Linear
Static.

a. Under the Analysis tab click
Entire Model in the Analyze
group.

b. Enter tee-clip_contact for Job
Name .

c. Click Solution Type.

d. Click Solution Parameters.

Step 4. Set Up and Run the Analysis

d

b

c

a
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Change the Bias on Tolerance.

a. Click Contact Parameters.

b. Click Contact Detection.

c. Change Bias on Tolerance (BIAS) to 0.0.

d. Click OK.

e. Click OK.

f. Click OK.

g. Click OK.

Step 4. Set Up and Run the Analysis (Cont.)

b
c

e
d

a

f
g
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Request a punch file that contains the MPCs used to model the glued contact.

a. Click Direct Text Input.

b. Select Case Control Section.

c. Enter NLOPRM MPCPCH=BEGN in the Case Control Section textbox.

d. Check CASE Write To Input Deck.

e. Click OK.

f. Click Apply.

Step 4. Set Up and Run the Analysis (Cont.)

a

c

b d

fe

NOTE: The Case Control Command entered here will create the
*.pch file containing the MPCs used to model the glued contact.
We will look at this to help determine the quality of the glued
contact.
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Attach the XDB analysis result file.

a. Click XDB in the Access
Results group

b. Click tee-clip_contact under
Available Jobs.

c. Click Apply.

Step 5. Attach the Results File

b

c

a
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Review the deformation results

a. Under the Results tab click Fringe/Deformation in the Quick Plot group.

b. Highlight Displacements, Translational under Select Fringe Result.

c. Highlight Displacements, Translational under Select Deformation Result.

d. Click Apply.

Step 6. Post-Process Results in Patran

b

c

d

a
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Review max principal stress.

a. Highlight Stress Tensor under
Select Fringe Result.

b. Pull down Max Principal for
Quantity.

c. Click Position … (At Z1)

d. Highlight At Z2

e. Click Close

f. Highlight Displacements,
Translational under Select
Deformation Result.

g. Click Apply.

Step 6. Post-Process Results in Patran (Cont.)

b

d

c

a

e

f

g
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a. Rotate the model and zoom in to focus
on the areas of interest

Step 6. Post-Process Results in Patran (Cont.)

NOTE: The stress results
on the flange are spotty,
with concentrations

a
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Import the *.pch file that contains
the MPCs used to model the glued
contact. This will help to check the
contact status.

a. Click Reset Graphics.

b. Pull down Display > Entity
Color/Label/Render.

c. Select Entity Type under
Entity Coloring and Labeling.

d. Click Apply.

e. Click Cancel.

Step 7. Import the Punch File

d

c

e

a

b
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a

Specify to keep the original node
numbering when importing the .pch
file.

a. Pull down File > Import.

b. Make sure Object and Source
are set to Model and
MSC.Nastran Input respectively.

c. Click MSC Nastran Input
Options.

d. Click Define Offsets.

e. Click in the cell in the Nodes row
and Offset/Maximum column.

f. Enter 0 for the Input Offset Value
and press Enter.

g. Click OK.

h. Click OK.

Step 7. Import the Punch File (Cont.)

d

f

h

g

e

b

c
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Look at the pattern of contact

a. Enter tee-clip_contact.pch for File name.

b. Click Apply.

c. Review the MSC Nastran Input File Import
Summary to verify that the MPCs have been
imported.

d. Click OK.

e. Change the display to Wireframe.

f. Observe the MPC pattern between the tee-
clip and the plate. Note that single MPCs
connect the two components and the edges
of the flange are unsupported.

Step 7. Import the Punch File (Cont.)

f

a b

d

c

e
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Modify the chip_3_pcb body pair:

a. Click Undo to remove the
MPCs

b. Under the Home tab, click
Show/Hide Model Browser
Tree in the Model Tree Group.

c. Double click on
plate_tee_contact under
Contact > Body Pair

d. Set the Contact
Detection(ISEARCH) to
Automatic.

e. Click OK

f. Click Apply

Step 8. Modify Body Pair

e

d

f

c

b

a
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Change the Contact Table to
reverse the contact search order.

a. Under the Analysis tab click
Entire Model in Analyze group.

b. Enter tee-clip_contact_2 for
Job Name.

c. Click Apply.

Step 9. Reverse the Search Order and Resubmit
the Analysis

b

c

a
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Post-process the analysis results.

a. Click XDB in Access Results
group.

b. Select tee-clip_contact_2
under Available Jobs.

c. Click Apply.

Step 10. Attach New Results File

c

b

a
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Review the max principal stresses.

a. Under the Results tab, click
Fringe/Deformation in the
Quick Plot group.

b. Highlight Default, A2: Static
Subcase under Select Result
Cases.

c. Highlight Stress Tensor under
Select Fringe Result.

d. Click Position … (At Z1)

e. Highlight At Z2.

f. Click Close.

g. Pull down Max Principal for
Quantity.

h. Highlight Displacements,
Translational under Select
Deformation Result.

i. Click Apply.

Step 11. Post-Process Results in Patran

b

c

g

h

i

e

f

d

a
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Step 11. Post-Process Results in Patran (Cont.)

NOTE: The stress pattern on the flange
is much smoother and the peak stress
has fallen by nearly 50%.
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Look at the updated MPC pattern.

a. Click Reset Graphics.

b. Pull down File > Import.

c. Make sure Object and Source are
set to Model and MSC.Nastran
Input respectively.

d. Click MSC Nastran Input
Options.

e. Click Define Offsets

f. Verify that Input Offset Value is 0

g. Click OK.

h. Click OK.

Step 12. Import the Punch File

b

e

h

c

d

a

f

g
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Look at the updated MPC pattern
(cont.)

a. Enter tee-clip_contact_2.pch
for File name.

b. Click Apply.

c. Review the MSC Nastran Input
File Import Summary to verify
that the MPCs have been
imported.

d. Click OK.

Step 12. Import the Punch File (Cont.)

ba

c

d
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Step 12. Import the Punch File (Cont.)

NOTE: The MPC pattern is much more extensive. The edges of the flange are now fully supported.
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WORKSHOP 6

CURVED SURFACE CONTACT
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• Workshop Objectives

– Demonstrate how fine-meshed parts can be included in coarser-meshed
models.

– Demonstrate Patran Automatic Contact Body and Body pair detection that
can detect multiple contact bodies with one click.

– Use the Distance Tolerance (ERROR) to achieve glued contact between
surfaces with gaps.

• Files Required

– wingskin_fe.bdf

• Software Version

– Nastran 2013.1

– Patran 2013
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• Suggested Steps:

1. Create a new Patran database.

2. Import the Nastran Input file, wingskin_fe.bdf.

3. Define Contact Bodies using Patran auto detect tool.

4. Define Contact Pairs

• Contact Pair between the Panels with tolerance of 0.003 and glued contact.

• Contact Pair between the Rib and panels with tolerance of 0.02 and glued
contact.

5. Verify the Boundary Conditions

6. Set up a linear static analysis with Contact results. Run the analysis.

7. Attach the MASTER/DBALL results

8. Review the Deformation shape.

9. Verify contact status.
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a

Create a new database. Name it
window_detail.db

a. Pull down File > New.

b. Enter window_detail as the
File name.

c. Click OK.

d. Pull down MSC.Nastran as the
Analysis Code.

e. Pull down Structural as
Analysis Type.

f. Click OK.

Step 1. Create a New Database

b c

d

e

f
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Import the Nastran Input file,
wingskin_fe.bdf.

a. Pull down File > Import

b. Pull down MSC.Nastran Input
for Source.

c. Select wingskin_fe.bdf

d. Click Apply

e. Review the Import Summary
and click OK

Step 2. Import the Model

a bc

d

e
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a. Click Iso 1 View in the
Orientation group.

b. Click Fit View in the Viewport
group.

c. Click Smooth Shaded in the
Display group.

Step 2. Import the Model (Cont.)

acb

NOTE: Notice that here
we have an airframe
model that has a very
fine mesh in the window
and some of its panels.
Other panels have a
comparatively coarser
mesh.
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Define Contact bodies using
Create Contact Body/Pair tool.

a. Pull down Tools > Modeling >
Contact Bodies/Pair

b. Pull down Method >
Connectivity

c. Check 2D for Elements.

d. Click Apply

e. Under the Loads/BCs tab, click
Color Code Bodies, in the
Contact Bodies group.

f. Highlight all three sets for
Existing Sets.

g. Select Group Color

h. Click Apply

Step 3. Define Contact Bodies

g

b

d

e

a

All Contact bodies will be
detected generated with one
click. Alternatively to
Connectivity Method, you can
use Properties and Contact will
be generated based on their
Properties and named
accordingly.

f

h
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Step 3. Define Contact Bodies (Cont.)

You can modify the light on the
view by Pulling down Display >
Light Sources and select more
Light Sources and click Apply
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Define Contact Pairs using Create Contact
Body/Pair tool.

a. Pull down Create > Body Pair.

b. Select Select Bodies in Create From.

c. Click Select Existing Bodies icon.

d. Highlight all Sets in Existing Bodies, except
2D_bdy5 and 2D_bdy6 (The Ribs).

e. Select Specify in Contact Properties Sets

f. Enter Panel_prop in Geometric Property.

g. Enter Panel_phy_prop in Physical Property.

h. Click Apply.

i. Click OK to close the Auto Creation Summary.

Step 4. Define Contact Pairs

a

b c

d

e
f

g

h

i
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Defining contact pair between the rib and
all the panels.

a. Enter 0.008 for Distance Tolerance.
This is a gap between the rib and
panels.

b. Select Entire Model in Create From.

c. Enter Rib_prop in Geometric Property.

d. Enter Rib_phy_prop in Physical
Property.

e. Click Apply.

f. Click OK.

g. Click No on all the Messages for
duplicate pairs.

h. Click Cancel to close the window.

Step 4. Define Contact Pairs (Cont.)

a

b

c

d

e
f

g

h
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Modify the contact pair parameters

a. Click Create Body Pair

b. Pull down Action > Modify

c. Pull down Object > Contact

d. Pull down Option > Body Pair

e. Select 2D_bdy1_2D_bd3_pair

f. Select Modify Data…

g. Enter 0.003 for Distance
Tolerance

h. Check Glue Contact, Retain
Gaps/Overlaps, Retain
Moment.

i. Check Stress Free InitCont

j. Select Automatic in Contact
Detection

k. Click Contact Option

l. Check Ignore Thickness for
both Bodies

m.Click OK

n. Click Apply

Step 4. Define Contact Pairs (Cont.)

b

c

d

e

f

g

h

i

k

j

m

l

n

a
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Modify the contact pair parameters

a. Select 2D_bdy1_2D_bd5_pair

b. Select Modify Data…

c. Enter 0.02 for Distance
Tolerance

d. Check Glue Contact, Retain
Gaps/Overlaps, Retain
Moment.

e. Check Stress Free InitCont

f. Select Automatic in Contact
Detection

g. Click OK

h. Click Apply

Step 4. Define Contact Pairs (Cont.)

a

b

c

d

e

f

g
h
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Create a pinned constraint on the
axial edges:

a. Click Reset Graphics.

b. Click Displacement
Constraint in the Nodal group

c. Pull down Action > Plot
Markers

d. Select Displ_spec1.1

e. Select Default_group

f. Click Apply

g. Select Press_pload4.1.2D

h. Click Apply

Step 5. View Boundary Conditions

d

b

e

f

g

c

h
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Set up the linear static analysis.

a. Under the Analysis tab, click
Entire Model in the Analyze
group.

b. Enter curved_glued_contact
for Job Name.

c. Click Solution Type.

d. Select Linear Static for
Solution Type.

e. Select Solution Parameters.

f. Select Results Output
Format.

g. Uncheck XDB and select
MASTER/DBALL

h. Select OK

i. Select OK

j. Select OK

Step 6. Set up Linear Static Analysis

a

d

c

b

e

f

g

h i

j
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Define glued contact between all
contact bodies, adjusting the
distance tolerance as required.

a. Click Subcases.

b. Highlight Default under
Available Subcases.

c. Click Output Requests on the
Subcases Form.

d. Highlight Contact Results for
Result Type.

e. Click OK.

f. Click Apply on the Subcases
form.

g. Click Cancel.

Step 6. Set up Linear Static Analysis (Cont.)

d

c

b

a

e gf
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Run the analysis.

a. Click Subcase Select.

b. Highlight Default in the top
pane. Ensure Default is the
only subcase present under
Subcases Selected.

c. Click OK.

d. Click Apply.

The job is written to
curved_glue_contact.bdf and
the analysis is run.

Step 6. Set up Linear Static Analysis (Cont.)

a

d

b

c
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Attach the MASTER/DBALL results:

a. Click MASTER/DBALL in the Access
Results group

b. Select curved_glued_contact from the
list of Available Jobs

c. Click Apply. Patran will look for the
results file with a name that matches
the Job Name.

Step 7. Attach the MASTER/DBALL Results

a

b

c
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Review the deformation results:

a. Click Reset Graphics.

b. Under the Results tab, click Fringe/Deformation in the Quick
Plot group.

c. Select the second subcase SC1:DEFAULT, A1 Static Subcase

d. Highlight Displacements, Translational for Fringe Result.

e. Highlight Displacements, Translational for Deformation Result.

f. Click Apply.

Step 8. Post Process with Patran

b

Check that the results
are reasonable. Note
that the displacement
contours flow across
the glued boundaries
with different mesh
sizes.

a

c

d

e

f



NAS133, Workshop 6, March 2014
Copyright© 2014 MSC.Software Corporation

WS6 - 20

Verify the contact status for each of the
contact bodies

a. Select Create/Marker/Scalar from the
Results menu.

b. Select the first Result Case SC0:,
A1:Static Subcase which contains the
contact results

c. Select Contact Status under Select
Scalar Result.

d. Click Display Attributes.

e. Set the Scale Factor to 0.03.

f. Set the Scalar Style to your preference.

g. Turn off Show Scalar Label.

h. Click Reset Graphics.

i. Select Apply.

The contact status plot for the fine mesh is
displayed on the next page.

Step 9. Verify Contact Status

a

b

c

e

f

g

i

h

d
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Step 9. Verify Contact Status (Cont.)

Patran will place a scalar symbol on
every node that is in contact.
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WORKSHOP 7

INTERFERENCE FIT
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• Workshop Objectives

– Perform an interference fit using both a fitted closure and geometric overlap

• Software Version

– MSC Nastran 2013.1

– Patran 2013

• Files Required

– Pipe_Model_Input.bdf
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• Suggested Steps

1. Create a new database.

2. Import the MSC Nastran input file Pipe_Model_Input.bdf.

3. Apply following boundary conditions:

• Constrain the plane of symmetry

• Fix both ends of the cylinders

4. Create deformable contact bodies for each of the following property set:

• Psolid_Fitted_Inner

• Psolid_Fitted_Outer

• Psolid_Overlap_Inner

• Psolid_Overlap_Outer

5. Define a contact pair such that the fitted inner and outer cylinders are
touching and the overlapping inner and outer cylinders are touching.

6. Run a Linear Static analysis:

• Set solution type to 101

• Select output format to be Master/Dball

• Request contact results

• Select subcase and create analysis deck

• Run the analysis using MSC Nastran
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• Suggested Steps Continued

7. Attach Master/Dball results file.

8. Post-Process using Patran:

• Create a fringe plot of von Mises Stress plot superimposed on the deformed
shape.

• Create a fringe plot of Contact Force
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Create a new database:

a. Pull down File > New

b. Enter Pipe_Model for File Name

c. Click OK.

d. Click OK on the New Model Preference
form to retain the default tolerance.

Step 1. Create a New Database

d
b c

a



NAS133, Workshop 7, March 2014
Copyright© 2014 MSC.Software Corporation

WS7 - 7

a
Import the MSC Nastran Input file
Pipe_Model_input.bdf:

a. Pull down File > Import…

b. Pull down MSC.Nastran Input
for Source.

c. Select Pipe_Model_Input.bdf
as the file to import.

d. Click Apply.

e. Check the Nastran Input File
Import Summary and make
sure there are 46864 Nodes,
33858 Elements.

f. Click OK.

g. Shade the model by clicking
Smooth shaded in the Display
group.

Step 2. Import the Model

b

d

e

c

f

g
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Create displacement constraint to
constrain the plane of symmetry

a. Under the Loads/BCs tab, click
Displacement Constraint in
the Nodal group

b. Enter New Set Name:
Fitted_Symmetry

c. Click Input Data

d. Enter Translations < ,0, >

e. Click in the Analysis Coordinate
Frame list box

f. Select the coordinate system at
the center of the bottom
cylinders.

g. Click OK

h. Click Select Application
Region

Step 3. Apply Boundary Conditions

b

c

d

e

g
h

f

a
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a. Pull down Select to FEM

b. Screen Select the Nodes as
shown

c. Click Add

d. Click OK

e. Click Apply

Step 3. Apply Boundary Conditions (Cont.)

a

b

c

d
e



NAS133, Workshop 7, March 2014
Copyright© 2014 MSC.Software Corporation

WS7 - 10

a. Enter New Set Name:
Overlap_Symmetry

b. Click Select Application Region

c. Screen Select the Nodes as shown

d. Click Add

e. Click OK

f. Click Input Data

Step 3. Apply Boundary Conditions (Cont.)

a

b

c

f

d

e
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a. Click in the Analysis Coordinate
Frame list box

b. Select the coordinate system at
the center of the top cylinders.

c. Click OK

d. Click Apply

Step 3. Apply Boundary Conditions (Cont.)

a

c

d

b
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Create a Displacement Constraint
to fix the ends of the cylinders

a. Under the Home tab, click
Right side view in the
Orientation group

b. Enter New Set Name:
Fitted_Fixed

c. Click Input Data

d. Enter Translations < 0 ,0 ,0 >

e. Click in the Analysis Coordinate
Frame list box

f. Select the coordinate system at
the center of the bottom
cylinder.

g. Click OK

h. Click Select Application
Region

Step 3. Apply Boundary Conditions (Cont.)

b

c

d

e

g

a

f

h
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a. Screen select the Nodes on the left end
of the lower cylinders as shown.

b. Click Add

c. Screen select Nodes on the right end of
the lower cylinders as shown.

d. Click Add

e. Click OK

f. Click Apply

Step 3. Apply Boundary Conditions (Cont.)

a

b

c

d

e

f
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a. Enter New Set Name: Overlap_Fixed

b. Click Input Data

c. Verify the Translations are < 0 ,0 ,0 >

d. Click in the Analysis Coordinate
Frame list box and select the
coordinate system at the center of the
top cylinders.

e. Click OK

f. Click Select Application Region

Step 3. Apply Boundary Conditions (Cont.)

a

b

c

d

e f
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a. Screen select the Nodes on the left end of
the upper cylinders as shown.

b. Click Add

c. Screen select Nodes on the right end of
the upper cylinders as shown.

d. Click Add

e. Click OK

f. Click Apply

Step 3. Apply Boundary Conditions (Cont.)

a

b

c

d

e

f
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Define four deformable bodies for
elements associated with each of
the four property sets.

a. Pull down Tools > Modeling
and select Contact
Bodies/Pairs…

b. Pull down Method to
Properties

c. Click Apply

d. Click Cancel

Step 4. Create Contact Bodies

b

c d

a
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Create touching Contact Pair between
Fitted Inner and Outer cylinders

a. Under the Loads/BCs tab click
Create Body Pair in the Body Pairs
group

b. Enter Fitted_pair for New Set Name

c. Click Input Data.

d. Enter pair1 for Property Set Name

e. Enter 0.95 for the Bias Factor (BIAS)

f. Enter 0.02 for the Interference
Closure

g. Select Automatic under Contact
Detection

h. Click OK

i. Click Select Application Region

j. Click Body1/Master/Touched icon
and select
Psolid_Fitted_Outer_bdy

k. Click Body2/Slave/Touching icon
and select
Psolid_Fitted_Inner_bdy

l. Click OK

m. Click Apply

Step 5. Create Contact Pairs

a

b

c

d

e

f

j

k

m

g

h
i

l
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Create touching Contact Pair
between Overlapping Inner and
Outer cylinders

a. Enter Overlap_pair for New
Set Name

b. Click Input Data.

c. Enter pair2 for Property Set
Name

d. Enter 0.03 for the Distance
Tolerance

e. Enter 0.95 for the Bias Factor
(BIAS)

f. Enter 0 for the Interference
Closure

g. Select Automatic under
Contact Detection

h. Click OK

i. Click Select Application
Region

j. Click Body1/Master/Touched
icon and select
Psolid_Overlap_Outer_bdy

k. Click Body2/Slave/Touching
icon and select
Psolid_Overlap_Inner_bdy

l. Click OK

m. Click Apply

Step 5. Create Contact Pairs (Cont.)

a

b

c

d

e

f

j

k

m

g

h

i

l
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Set Solution Type to 101 and request
output format as MASTER/DBALL.

a. Under the Analysis tab, click
Analysis Deck in the Create
group

b. Enter Job Name:
Pipe_Model_Interference

c. Click Solution Type…

d. Click Solution Parameters…

e. Click Results Output Format

f. Uncheck Print and check XDB
and Master/DBALL

g. Click OK on all forms

Step 5. Set Up and Run the Analysis

b

c
d

e

f

g
g

g

a
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Modify the Default subcase to
include contact results.

a. Click Subcases.

b. Under Available Subcases
highlight Default

c. Click Output Requests

d. Highlight Contact Results

e. Click OK

f. Click Apply

g. Click Cancel

Step 5. Set Up and Run the Analysis (Cont.)

a

b

c

d

e f g
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Select the Default subcase and
create an analysis deck.

a. Click Subcase Select.

b. Make sure Default is selected

c. Click OK

d. Click Apply

Step 5. Set Up and Run the Analysis (Cont.)

a

b

c d
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Run the
Pipe_Model_Interference.bdf file
using MSC Nastran.

a. Click the MSC Nastran 2013.1
icon on your Desktop.

b. Browse to and select
Pipe_Model_Interference.bdf.

c. Click Open.

d. Under Optional keywords enter:
memory=50m to allocate more
memory for running this analysis.

e. Click Run.

Step 5. Set Up and Run the Analysis (Cont.)

a

b

c

d

e
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Attach result file:

a. Under the Analysis tab, click
MASTER/DBALL in the Access
Results Group.

b. Click Select Results File.

c. Browse to and select
pipe_model_interference.MASTER.

d. Click OK

e. Click Apply

Step 6. Attach Results File

b

c

d

e

a
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Create a fringe plot of von Mises
Stress plot superimposed on the
deformed shape.

a. Under Results tab, click
Fringe/Deformation in the
Quick Plot group.

b. Highlight SC1:DEFAULT,
A1:Static Subcase

c. Under Select Fringe Result,
highlight Stress Invariants,
von Mises

d. Under Select Deformation
Result, highlight
Displacement, Translational

e. Click Apply

Step 7. Post-Process with Patran

b

c

d

e

a
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Step 7. Post-Process with Patran (Cont.)
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Create a fringe plot of Contact
Force

a. Under Select Fringe Result,
highlight Contact force,
Normal

b. Click Apply

Step 7. Post-Process with Patran (Cont.)

a

b
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Step 7. Post-Process with Patran (Cont.)
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WORKSHOP 8

BOLTED-JOINT ANALYSIS
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• Workshop Objectives

– Compare SOL 101 and SOL 400 analyses for a bolted joint.

– Note that in SOL 101 bolt preload cannot be applied whereas in SOL 400
bolt preload can be applied.

• Software Version

– MSC Nastran 2013.1

– Patran 2013

• Files Required

– bolted_joint.db
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• Problem Description

– Two aluminum fittings are bolted together. The Upper Fitting is constrained
to only be able to move in the Z direction and is loaded with 1000 lbs. The
Lower Fitting is fixed at the bottom. A steel bolt and nut holds the two
fittings together. The bolt is glued to the lower fitting to stabilize the bolt/nut
body.

Upper Aluminum Fitting
0.1” mesh

Lower Aluminum fitting
0.11” meshLower Fitting

bottom face fixed

Constrained in
DOF 12456

Steel Bolt and Nut
0.1” mesh

RBE2

1000.0

Upper Fitting
applied load
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• Suggested Steps
– PART 1, SOL 101
1. Open and review starting model.

2. Create three deformable contact bodies using the Contact Body/Pair Tool :
• Upper_fitting

• Lower_fiiting

• Bolt

3. Create a glued body pair between Lower_Fitting and Bolt and two touching body
pairs between Upper_Fitting and Bolt and Upper_Fitting and Lower_Fitting.

4. Set up one load case, called loadcase_sol101, to apply the external load.

5. Set up a SOL 101:
• Set Solution Type to Linear Static, SOL101

• Set up Separation Criterion to Stresses and Derivation to Extrapolation

• Select the Results Output to be XDB

• Set up Load Increment Parameter to 1 fixed increment

• Create Output Request for contact results

• Apply changes to Loadcase_sol101

• Select Loadcase_sol101 and run the job

6. Review the MSC Nastran input file.

7. Review the MSC Nastran results file.

8. Attach the MSC Nastran results file.

9. Review analysis results, both stresses and deformation.
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• Suggested Steps (Cont.)

– PART 2, SOL 400

1. Create Bolt Preload:

• Axial Bolt Load = 2000 lbs.

• Vector Magnitude = 0.6

• Direction Vector = <0 0 1>

2. Create SPC for Locking the Bolt Preload:

• Constrain the Bolt in the Axial Direction

3. Set up three load cases:

• One to preload the bolt

• One to lock the bolt in position

• One to apply the external load

4. Set up a SOL 400. All parameters for the three loadcases are same as SOL101
except the Load Increments as defined below:

• Preload = 2

• Bolt_lock = 1

• External_Load = blank for default

5. Review the MSC Nastran input file.

6. Review the MSC Nastran results file.

7. Attach MSC Nastran results file.

8. Review analysis results, both the stresses and deformation.
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PART 1

SOL 101
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Open the starting model.

a. Pull Down File > Open.

b. Select bolted_joint.db.

c. Click OK.

Step 1. Open and Review the Starting Model

b

c

a
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Review the model.

a. The Lower Fitting is fixed at the
bottom.

b. The Upper Fitting is
constrained in all degrees of
freedom except axial
translations.

c. The Upper Fitting has an
applied load of 1000.0 lbs. in
the Z direction. To see the load
value, click the Wireframe
icon.

d. Click Smooth Shaded.

Step 1. Open and Review Starting Model (Cont.)

Constrained
in DOF 12456

Lower Fitting
fixed bottom

c

b

d

a
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Define Contact Bodies using the Create Contact
Body/Pair Tool:

a. Pull down Tools > Modeling > Contact
Bodies/Pair

b. Pull down Method to Connectivity

c. Check 3D for Elements.

d. Click Apply

e. Click Cancel

f. Turn on the Model Browser Tree

g. Double click on 3D_bdy under Contact >
Deformable Body

h. Click OK (not shown)

i. Enter upper_fitting for Rename Set as.

j. Click Apply

k. Rename 3D_bdy1 as lower_fitting and 3D_bdy2
as bolt

Step 2. Define Three Deformable Contact Bodies

g

j

k

i

f

a

c

b

ed
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Create Three New Body Pairs:

a. Under the Load/BCs tab click
Create Body Pair in the Body
Pairs group.

b. Enter bolt_lower_fitting for
New Set Name.

c. Click Input Data…

d. Enter bolt_lower_fitting_g for
Property set name.

e. Check Glued Contact(IGLUE)

f. Click OK

g. Click Select Application
Region

h. Click Select Existing Touched
Body

i. Select lower_fitting

j. Click Select Existing
Touching Body

k. Select bolt

l. Click OK

m. Click Apply

Step 3. Create Body Pairs

b

c

l

a

e

f

g

h

j

ik

m

d
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Create Three New Body Pairs:

a. Enter bolt_upper_fitting for New Set Name.

b. Click Input Data…

c. Enter bolt_upper_fitting_g for Property set
name.

d. Uncheck Glued Contact(IGLUE)

e. Click OK

f. Click Select Application Region

g. Click Select Existing Touched Body

h. Select upper_fitting

i. Click Select Existing Touching Body

j. Select bolt

k. Click OK

l. Click Apply

Step 3. Create Body Pairs (Cont.)

b

d

l

a

e

f

gj

h

i

k

c
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Create Three New Body Pairs:

a. Enter lower_upper_fitting for New Set
Name.

b. Click Input Data…

c. Enter lower_upper_fitting_g for New
Set Name.

d. Click OK

e. Click Select Application Region

f. Click Select Existing Touched Body

g. Select upper_fitting

h. Click Select Existing Touching Body

i. Select lower_fitting

j. Click OK

k. Click Apply

Step 3. Create Body Pairs (Cont.)

b

d

c

a

e

fi

h

j

g

k



NAS133, Workshop 8, March 2014
Copyright© 2014 MSC.Software Corporation

WS8 - 14

Set up a second load case to
apply the bolt lock.

a. Under the Loads/BCs tab,
click Create Load Case
from the Load Cases
Group.

b. Enter loadcase_sol101 as
the Load Case Name.

c. Click Input Data.

d. Select all the Loads/BCs
list under Select Individual
Loads/BCs.

Step 4. Set up Load Case

c

b

d

a
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Set up second load case continued.

a. The table should now look like the one shown below.

b. Click OK.

c. Click Apply.

Step 4. Set up Load Case (Cont.)

a

b
c
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a

Set the Solution Type to 101,
Linear Static.

a. Under the Analysis tab, click on
Entire Model in the Analyze
group.

b. Click Solution Type.

c. Confirm that LINEAR STATIC
is selected for the Solution
Type.

d. Click Solution Parameters.

Step 5. Set up SOL 101 and Run Analysis

b

c

d
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Set up Separation Criterion.

a. Click Contact Parameters.

b. Select Separation.

c. Select Stresses for Separation
Criterion.

d. Select Extrapolation for
Derivation.

e. Click OK.

f. Click OK.

Step 5. Set up SOL 101 and Run Analysis (Cont.)

b

f

c

e

d a
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Select the Results Output Format

a. Select Results Output
Format.

b. Check XDB.

c. Click OK.

d. Click OK.

e. Click OK.

Step 5. Set up SOL 101 and Run Analysis (Cont.)

d
e

a
c

b
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Set up Load Increment

a. Click Subcases.

b. Click on loadcase_sol101
under Available Subcases.

c. Click Subcase Parameters.

d. Select Load Increment
Params.

e. Enter 1 for Number of
Increments.

f. Click OK.

g. Click OK

Step 5. Set up SOL 101 and Run Analysis (Cont.)

a

c

b

d

e

f
g
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Create Output Request for contact
results.

a. Click Output Requests.

b. Select Contact Results.

c. Click OK.

Step 5. Set up SOL 101 and Run Analysis (Cont.)

a

b

c
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Apply changes to the subcase.

a. Click Apply.

b. Click Cancel.

Step 5. Set up SOL 101 and Run Analysis (Cont.)

a b
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Select the subcase and submit the
analysis job.

a. Click Subcase Select.

b. Select loadcase_sol101.

c. Select Default from the
Subcases Select to remove it
from the list.

d. Click OK.

e. Set the Job Name to
bolted_joint_101.

f. Click Apply to submit the job.

Step 5. Set up SOL 101 and Run Analysis (Cont.)

a

b

d

f

c

e
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While the job is running, review the MSC Nastran input file.

a. Locate the file bolted_joint_101.bdf.

b. Open bolted_joint_101.bdf with any text editor.

Step 6. Review Input File

a

b
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PARAM POST 0
PARAM PRTMAXIM YES
BCPARA 0 NLGLUE 0 IBSEP 4

Review the MSC Nastran input file
continued.

a. Check the BCPARA Entry.

b. Check Subcase 1.

c. Close the input file.

Step 6. Review Input File (Cont.)

Relative stress based separation criterion

Contact

Fixed Conditions

Applied Load

a

b
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After completion of the run, review the .f06 results file.

a. Locate the file bolted_joint_101.f06.

b. Open bolted_joint_101.f06 with any text editor.

c. Search for “%” and scan the .f06 file.

d. Close the .f06 file.

Step 7. Review Results File

a

b

c
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Post process analysis results in
Patran.

a. Under the Analysis tab, click
XDB from the Access Results
Group.

b. Select bolted_joint_101 from
the Available Jobs.

c. Click Apply.

Step 8. Attach Results File

a

b

c
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Examine von Mises stresses.

a. Under the Results tab, click Fringe/Deformation from the Quick Plot group.

b. Select loadcase_sol101 from Select Result Cases.

c. Select Stress Tensor for Fringe Result.

d. Click Apply.

Step 9. Review Analysis Results

c

d

b

a

The model’s display
has been changed to
Wireframe through
the Display option
under the Home tab.
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Examine deformation.

a. Unselect Stress Tensor by
double-clicking on it.

b. Select Displacement,
Translational for deformation
result.

c. Click the Deform Attributes
icon.

d. Select Shaded for the Render
Style.

e. Make sure that Model Scale is
selected.

f. Uncheck Show Undeformed.

g. Click Apply.

h. Plot again, but this time select
True Scale to see the
difference between the two.
Both plots are shown on the
next page.

i. Click Smooth Shaded.

Step 9. Review Analysis Results (Cont.)

a

b

d

e

g

c

f

j

h
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Step 9. Review Analysis Results (Cont.)

Model Scale True Scale
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PART 2

SOL 400
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First show only the bolt.

a. Pull down Group > Post.

b. Select Bolt from the Select
Groups to Post list.

c. Click Apply.

d. Click Cancel.

e. Click the Fit View icon.

Step 1. Create Bolt Preload

a

b

c d

e
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Create bolt preload.

a. Pull Down Tools > Modeling >
Bolt Preload…

b. Verify that MPC Type is set to
Overclosure.

c. Enter Axial Bolt Load of 2000.

d. For Control Node Offset, enter
<0 0 1> for the Direction Vector
and 0.6 for the Vector
Magnitude.

e. Click in the Element List box.

f. Rectangular pick all the bolt
elements and watch the bolt
preload being created.

g. Click Cancel.

Step 1. Create Bolt Preload (Cont.)

a

b

d

e

g

f

Watch out. The Auto
Execute box is checked.
So don’t click on Apply.

c
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Create an SPC to lock the bolt in
the second load step.

a. Under the Loads/BCs tab, click
on Displacement Constraint
in the Nodal group.

b. Enter bolt_lock as name.

c. Click Input Data…

d. Enter < ,0, > to constrain the Y
translation in the local bolt
coordinate system.

e. Click in the Analysis Coordinate
Frame box, then screen pick
Coord 2, the coordinate frame
in the bolt.

f. Click OK.

g. Click Select Application
Region.

Step 2. Create SPC to Lock Bolt Preload

c

b

a

d

e

e

f

g
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Create an SPC to lock the bolt in
the second load step continued.

a. Set Select to FEM.

b. Screen pick the bolt preload
control node.

c. Click Add.

d. Click OK.

e. Click Apply.

Step 2. Create SPC to Lock Bolt Preload (Cont.)

a

b

b

c

d

e
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Set up a load case to preload
the bolt

a. Under the Loads/BCs
tab, click Create Load
Case from the Load
Cases Group.

b. Set Action to Modify.

c. Select loadcase_sol101
from the Existing Load
Cases list

d. Click bolt_lock to select
this row.

e. Click Remove Selected
Rows.

f. Click Applied_Load to
select this row.

g. Click Remove Selected
Rows.

Step 3. Set Up Three Load Cases

a

b

c

d

e

f

g
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a. The table should look
like the one shown on
the right.

b. Click OK.

c. Enter Preload in the
Rename Loadcase as
textbox.

d. Click Apply.

This first load step is used to
preload the bolt. No
external load is applied.

Step 3. Set Up Three Load Cases (Cont.)

b

a

d

c
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Set up a second load case to
apply the bolt lock.

a. Select Default from the
Existing Load Cases list.

b. Click Applied_Load to
select this row.

c. Click Remove Selected
Rows.

d. Click
Displ_bolt_1_LateralDisp
and Displ_bolt_lock to
add them to the table
below.

Step 3. Set Up Three Load Cases (Cont.)

a

c

d

b
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a. The table should now
look like the one shown
on the right.

b. Click OK.

c. Enter Bolt_Lock in the
Rename Loadcase as
textbox.

d. Click Apply.

Step 3. Set Up Three Load Cases (Cont.)

a

b d

c
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Set up a third load case to apply
the external load.

a. Set Action to Create.

b. Enter External_Load as the
Load Case Name.

c. Click Input Data.

d. Select Preload from the
Existing Load Cases list.

e. Click bolt_1 to select this row.

f. Click Remove Selected Rows.

g. Click Disp_bolt_lock to add to
table below.

h. Click Force_Applied_Load to
add to table below.

Step 3. Set Up Three Load Cases (Cont.)

b

a

e

f

c

g
h

d
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a. The table should now
look like the one
shown on the right.

b. Click OK.

c. Click Apply.

Step 3. Set Up Three Load Cases (Cont.)

a

b
c
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a

Select the Solution Type.

a. Under the Analysis tab, click on
Entire Model in the Analyze
group.

b. Click Solution Type.

c. Select IMPLICIT NONLINEAR,
SOL400

d. Click Solution Parameters.

Step 4. Set Up SOL 400 and Run the Analysis

b

c

d
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b

f

Set up Separation Criterion

a. Click Contact Parameters.

b. Select Separation.

c. Confirm Stresses for Separation
Criterion.

d. Confirm Extrapolation for Derivation.

e. Click OK.

f. Click OK.

Step 4. Set Up SOL 400 and Run Analysis (Cont.)

e

dc

a
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Select the Output results format.

a. Select Results Output
Format.

b. Check XDB.

c. Click OK.

d. Click OK.

e. Click OK.

Step 4. Set Up SOL 400 and Run Analysis (Cont.)

d e

a
c

b
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Set up Load Increment for the
Preload subcase.

a. Click Subcases.

b. Click on Preload under
Available Subcases.

c. Click Subcase Parameters.

d. Select Load Increment
Params.

e. Enter 2 for Number of
Increments.

f. Click OK.

Step 4. Set Up SOL 400 and Run Analysis (Cont.)

a
c

b

d

e

f
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Create Output Request for the
Preload subcase.

a. Click Output Requests.

b. Select Contact Results.

c. Click OK.

d. Click Apply to finish setting up
the Preload subcase.

Step 4. Set Up SOL 400 and Run Analysis (Cont.)

a

b

c d
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Set up Load Increment for the
Bolt_Lock subcase

a. Select Bolt_Lock from
Available Subcases.

b. Click Subcase Parameters.

c. Click Load Increment
Params.

d. Enter 1 for Number of
Increments.

e. Click OK.

Step 4. Set Up SOL 400 and Run Analysis (Cont.)

a

b
cd

e
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Create Output Request for the
Bolk_Lock subcase.

a. Click Output Requests.

b. Select Contact Results.

c. Click OK.

d. Click Apply to finish setting
up the Bolt_Lock subcase.

Step 4. Set Up SOL 400 and Run Analysis (Cont.)

a

b

c d
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Set up the Load Increment for the
External Load subcase

a. Select External_Load from
Available Subcases.

b. Click Subcase Parameters.

c. Click Load Increment
Params.

d. Note that the Number of
Increments is not specified,
therefore the default value of
10 increments will be used.
(See NLPARM in the Bulk Data
Entries chapter of the MSC
Nastran Quick Reference
Guide)

e. Click OK.

Step 4. Set Up SOL 400 and Run Analysis (Cont.)

a

b

cd

e
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Create Output Request for the
External_Load subcase.

a. Click Output Requests.

b. Select Contact Results.

c. Click OK.

d. Click Apply to finish setting up
the External_Load subcase.

e. Click Cancel.

Step 4. Set Up SOL 400 and Run Analysis (Cont.)

a

b

c d e
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Select all three subcases
and run the analysis.

a. Click Subcase
Select.

b. From the Load Steps
for Solution Sequence
400 list, select
Preload.

c. From the Load Steps
for Solution Sequence
400 list, select
Bolt_Lock.

d. From the Load Steps
for Solution Sequence
400 List, select
External_Load.

e. Check that all three
load steps appear
under Load Steps
Selected in the order
shown.

f. Click OK.

g. For the Job Name,
enter
bolted_joint_400.

h. Click Apply to submit
the job.

Step 4. Set Up SOL 400 and Run Analysis (Cont.)

a

c

h

b
d

g

e

f
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While the job is running, review the
MSC Nastran input file.

a. Locate the file
bolted_joint_400.bdf.

b. Open bolted_joint_400.bdf
with any text editor.

Step 5. Review Input File

a

b
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While the job is running, review the MSC Nastran input file continued.

a. Notice the entry BOLT that defines a rigid bolt by a set of MPC
constraints.

b. Notice the three subcases that you set up.

c. Check the BCPARA entry.

Step 5. Review Input File (Cont.)

Preload

Bolt Lock

Relative stress based separation criterion

External Load

Bolt Definition

a

b

c
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After completion of the run, review the .f06 results file.

a. Locate the file bolted_joint_400.f06 and open with any text editor.

b. Search for “%” and scan the .f06 file

c. Close the .f06 file.

Step 6. Review Results File

a

a

b

c
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c

Post process analysis results in
Patran.

a. Under the Analysis tab, click
XDB from the Access Results
Group.

b. Under the Available Jobs,
select bolted_joint_400.

c. Click Apply.

Step 7. Attach Results File

a

b
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Step 8. Review Analysis Results

Post the entire bolted_joint model.

a. Select Post from the Group menu.

b. Click Select All.

c. Click Apply.

d. Click Cancel.

a

b

c d
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Examine von Mises stresses.

a. Under the Results tab, click Fringe/Deformation from the Quick Plot group.

b. Select 100% of Load.

c. Select Stress Tensor for Fringe Result.

d. Click Apply.

e. Repeat for 300% of Load. This plot shown on the next page.

Step 8. Review Analysis Results (Cont.)
a

c

d

b
e
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Step 8. Review Analysis Results (Cont.)
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Examine deformation.

a. Select 100% of Load.

b. Unselect Stress Tensor by
clicking on it.

c. Select Displacement,
Translational for deformation
result.

d. Click the Deform Attributes
icon.

e. Select Shaded for the Render
Style.

f. Uncheck Show Undeformed.

g. Click Apply.

h. Repeat for 300% of Load.

i. Both plots are shown on the
following page.

Step 8. Review Analysis Results (Cont.)

b

c

a
e

f

g

d

h
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Step 8. Review Analysis Results (Cont.)

100% of Load 300% of Load
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